distribution/projects/Rockchip/packages/u-boot/patches/RK3588/000-fix-gcc12.patch
2023-01-08 22:49:32 +00:00

13 lines
430 B
Diff
Executable file

diff --git a/Makefile b/Makefile
index 590fd4c1f..3165ec95f 100644
--- a/Makefile
+++ b/Makefile
@@ -606,6 +606,8 @@ endif
KBUILD_CFLAGS += $(call cc-option,-Wno-format-nonliteral)
KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
+KBUILD_CFLAGS += $(call cc-disable-warning, dangling-pointer)
+KBUILD_CFLAGS += $(call cc-disable-warning, address)
# turn jbsr into jsr for m68k
ifeq ($(ARCH),m68k)