distribution/packages/games/libretro/yabasanshiro/patches/rk3399.patch
fewtarius b2d76a6e53
* Deprecate and remove Python2 thanks to @CoreELEC as an upstream.
* Optimize mupen64plus, plus-nx, and yabasanshiro a bit
* Misc OS updates and bug fixes.
2022-02-27 18:34:12 -05:00

18 lines
839 B
Diff

diff -rupN yabasanshiro.orig/yabause/src/libretro/Makefile yabasanshiro/yabause/src/libretro/Makefile
--- yabasanshiro.orig/yabause/src/libretro/Makefile 2022-02-27 14:51:53.958685169 -0500
+++ yabasanshiro/yabause/src/libretro/Makefile 2022-02-27 14:57:08.993824415 -0500
@@ -155,11 +155,12 @@ else ifneq (,$(findstring rockpro64,$(pl
SHARED := -shared -Wl,--no-undefined -Wl,--version-script=link.T
LDFLAGS += -lpthread
ARCH_IS_LINUX = 1
+ FLAGS += -DAARCH64
HAVE_SSE = 0
FORCE_GLES = 1
- USE_ARM_DRC = 1
+ USE_AARCH64_DRC = 1
DYNAREC_DEVMIYAX = 1
- FLAGS += -march=armv8-a+crc -mcpu=cortex-a72 -mtune=cortex-a72.cortex-a53 -mfloat-abi=hard -mfpu=neon-vfpv4 -mvectorize-with-neon-quad
+ FLAGS += -march=armv8-a+crc -mcpu=cortex-a72 -mtune=cortex-a72.cortex-a53
# Rpi4 (64-bit)
else ifeq ($(platform), rpi4)