79 lines
3.3 KiB
Diff
79 lines
3.3 KiB
Diff
diff -rupN parallel-n64.orig/Makefile parallel-n64/Makefile
|
|
--- parallel-n64.orig/Makefile 2023-01-08 13:17:14.937637431 +0000
|
|
+++ parallel-n64/Makefile 2023-01-08 13:17:57.606530001 +0000
|
|
@@ -134,6 +134,15 @@ ifneq (,$(findstring unix,$(platform)))
|
|
GL_LIB := -lGL
|
|
endif
|
|
|
|
+ # RK3588
|
|
+ ifneq (,$(findstring RK3588,$(platform)))
|
|
+ TARGET := $(TARGET_NAME)_libretro.so
|
|
+ CPUFLAGS += -DARM_FIX -DCLASSIC
|
|
+ GLES = 1
|
|
+ GL_LIB := -lGLESv2
|
|
+ WITH_DYNAREC = aarch64
|
|
+ endif
|
|
+
|
|
# Raspberry Pi
|
|
ifneq (,$(findstring rpi,$(platform)))
|
|
GLES = 1
|
|
diff -rupN parallel-n64.orig/libretro/libretro.c parallel-n64/libretro/libretro.c
|
|
--- parallel-n64.orig/libretro/libretro.c 2023-01-08 13:17:14.945637598 +0000
|
|
+++ parallel-n64/libretro/libretro.c 2023-01-08 13:30:37.562604648 +0000
|
|
@@ -400,7 +400,9 @@ static void setup_variables(void)
|
|
#if defined(HAVE_OPENGL) || defined(HAVE_OPENGLES)
|
|
"|glide64|gln64|rice"
|
|
#endif
|
|
+#ifdef HAVE_THR_AL
|
|
"|angrylion"
|
|
+#endif
|
|
#ifdef HAVE_PARALLEL
|
|
"|parallel"
|
|
#endif
|
|
@@ -410,7 +412,9 @@ static void setup_variables(void)
|
|
#if defined(HAVE_OPENGL) || defined(HAVE_OPENGLES)
|
|
"|hle"
|
|
#endif
|
|
+#ifdef HAVE_THR_AL
|
|
"|cxd4"
|
|
+#endif
|
|
#ifdef HAVE_PARALLEL_RSP
|
|
"|parallel"
|
|
#endif
|
|
@@ -418,16 +422,18 @@ static void setup_variables(void)
|
|
#if defined(HAVE_OPENGL) || defined(HAVE_OPENGLES) || defined(HAVE_PARALLEL)
|
|
{ "parallel-n64-screensize",
|
|
#ifdef CLASSIC
|
|
- "Resolution (restart); 320x240|640x480|960x720|1280x960|1440x1080|1600x1200|1920x1440|2240x1680|2880x2160|5760x4320" },
|
|
+ "Resolution (restart); 320x240|640x480|960x720|1440x1080" },
|
|
#else
|
|
- "Resolution (restart); 640x480|960x720|1280x960|1440x1080|1600x1200|1920x1440|2240x1680|2880x2160|5760x4320|320x240" },
|
|
+ "Resolution (restart); 320x240|640x480|960x720|1440x1080" },
|
|
#endif
|
|
{ "parallel-n64-aspectratiohint",
|
|
"Aspect ratio hint (reinit); normal|widescreen" },
|
|
{ "parallel-n64-filtering",
|
|
"(Glide64) Texture Filtering; automatic|N64 3-point|bilinear|nearest" },
|
|
+#ifdef HAVE_THR_AL
|
|
{ "parallel-n64-dithering",
|
|
"(Angrylion) Dithering; enabled|disabled" },
|
|
+#endif
|
|
{ "parallel-n64-polyoffset-factor",
|
|
"(Glide64) Polygon Offset Factor; -3.0|-2.5|-2.0|-1.5|-1.0|-0.5|0.0|0.5|1.0|1.5|2.0|2.5|3.0|3.5|4.0|4.5|5.0|-3.5|-4.0|-4.5|-5.0"
|
|
},
|
|
@@ -435,6 +441,7 @@ static void setup_variables(void)
|
|
"(Glide64) Polygon Offset Units; -3.0|-2.5|-2.0|-1.5|-1.0|-0.5|0.0|0.5|1.0|1.5|2.0|2.5|3.0|3.5|4.0|4.5|5.0|-3.5|-4.0|-4.5|-5.0"
|
|
},
|
|
#endif
|
|
+#ifdef HAVE_THR_AL
|
|
{ "parallel-n64-angrylion-vioverlay",
|
|
"(Angrylion) VI Overlay; Filtered|AA+Blur|AA+Dedither|AA only|Unfiltered|Depth|Coverage"
|
|
},
|
|
@@ -445,6 +452,7 @@ static void setup_variables(void)
|
|
"(Angrylion) Multi-threading; all threads|1|2|3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31|32|33|34|35|36|37|38|39|40|41|42|43|44|45|46|47|48|49|50|51|52|53|54|55|56|57|58|59|60|61|62|63" },
|
|
{ "parallel-n64-angrylion-overscan",
|
|
"(Angrylion) Hide overscan; disabled|enabled" },
|
|
+#endif
|
|
{ "parallel-n64-virefresh",
|
|
"VI Refresh (Overclock); auto|1500|2200" },
|
|
{ "parallel-n64-bufferswap",
|