233 lines
8.8 KiB
Diff
233 lines
8.8 KiB
Diff
diff -Naur lame-3.98.4/configure.in lame-3.98.4.patch/configure.in
|
|
--- lame-3.98.4/configure.in 2010-03-22 21:40:17.000000000 +0100
|
|
+++ lame-3.98.4.patch/configure.in 2011-03-25 12:11:44.982662225 +0100
|
|
@@ -21,6 +21,8 @@
|
|
AC_INIT([lame],[3.98.4],[lame-dev@lists.sf.net])
|
|
AC_CONFIG_SRCDIR([libmp3lame/lame.c])
|
|
|
|
+AC_CONFIG_MACRO_DIR([m4])
|
|
+
|
|
dnl check system
|
|
AC_CANONICAL_HOST
|
|
|
|
@@ -385,7 +387,7 @@
|
|
|
|
dnl configure use of features
|
|
|
|
-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
|
|
+AM_PATH_GTK_2_0(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
|
|
|
|
dnl ElectricFence malloc debugging
|
|
AC_MSG_CHECKING(use of ElectricFence malloc debugging)
|
|
diff -Naur lame-3.98.4/m4/gtk-2.0.m4 lame-3.98.4.patch/m4/gtk-2.0.m4
|
|
--- lame-3.98.4/m4/gtk-2.0.m4 1970-01-01 01:00:00.000000000 +0100
|
|
+++ lame-3.98.4.patch/m4/gtk-2.0.m4 2010-12-22 03:34:53.000000000 +0100
|
|
@@ -0,0 +1,196 @@
|
|
+# Configure paths for GTK+
|
|
+# Owen Taylor 1997-2001
|
|
+
|
|
+dnl AM_PATH_GTK_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
|
|
+dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
|
|
+dnl pass to pkg-config
|
|
+dnl
|
|
+AC_DEFUN([AM_PATH_GTK_2_0],
|
|
+[dnl
|
|
+dnl Get the cflags and libraries from pkg-config
|
|
+dnl
|
|
+AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
|
|
+ , enable_gtktest=yes)
|
|
+
|
|
+ pkg_config_args=gtk+-2.0
|
|
+ for module in . $4
|
|
+ do
|
|
+ case "$module" in
|
|
+ gthread)
|
|
+ pkg_config_args="$pkg_config_args gthread-2.0"
|
|
+ ;;
|
|
+ esac
|
|
+ done
|
|
+
|
|
+ no_gtk=""
|
|
+
|
|
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
|
|
+
|
|
+ if test x$PKG_CONFIG != xno ; then
|
|
+ if pkg-config --atleast-pkgconfig-version 0.7 ; then
|
|
+ :
|
|
+ else
|
|
+ echo "*** pkg-config too old; version 0.7 or better required."
|
|
+ no_gtk=yes
|
|
+ PKG_CONFIG=no
|
|
+ fi
|
|
+ else
|
|
+ no_gtk=yes
|
|
+ fi
|
|
+
|
|
+ min_gtk_version=ifelse([$1], ,2.0.0,$1)
|
|
+ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
|
|
+
|
|
+ if test x$PKG_CONFIG != xno ; then
|
|
+ ## don't try to run the test against uninstalled libtool libs
|
|
+ if $PKG_CONFIG --uninstalled $pkg_config_args; then
|
|
+ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
|
|
+ enable_gtktest=no
|
|
+ fi
|
|
+
|
|
+ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
|
|
+ :
|
|
+ else
|
|
+ no_gtk=yes
|
|
+ fi
|
|
+ fi
|
|
+
|
|
+ if test x"$no_gtk" = x ; then
|
|
+ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
|
|
+ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
|
|
+ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
|
|
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
|
|
+ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
|
|
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
|
|
+ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
|
|
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
|
|
+ if test "x$enable_gtktest" = "xyes" ; then
|
|
+ ac_save_CFLAGS="$CFLAGS"
|
|
+ ac_save_LIBS="$LIBS"
|
|
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
|
|
+ LIBS="$GTK_LIBS $LIBS"
|
|
+dnl
|
|
+dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
|
|
+dnl checks the results of pkg-config to some extent)
|
|
+dnl
|
|
+ rm -f conf.gtktest
|
|
+ AC_TRY_RUN([
|
|
+#include <gtk/gtk.h>
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+
|
|
+int
|
|
+main ()
|
|
+{
|
|
+ int major, minor, micro;
|
|
+ char *tmp_version;
|
|
+
|
|
+ fclose (fopen ("conf.gtktest", "w"));
|
|
+
|
|
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
|
|
+ tmp_version = g_strdup("$min_gtk_version");
|
|
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, µ) != 3) {
|
|
+ printf("%s, bad version string\n", "$min_gtk_version");
|
|
+ exit(1);
|
|
+ }
|
|
+
|
|
+ if ((gtk_major_version != $gtk_config_major_version) ||
|
|
+ (gtk_minor_version != $gtk_config_minor_version) ||
|
|
+ (gtk_micro_version != $gtk_config_micro_version))
|
|
+ {
|
|
+ printf("\n*** 'pkg-config --modversion gtk+-2.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
|
|
+ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
|
|
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
|
+ printf ("*** was found! If pkg-config was correct, then it is best\n");
|
|
+ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
|
|
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
|
|
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
|
|
+ printf("*** required on your system.\n");
|
|
+ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
|
|
+ printf("*** to point to the correct configuration files\n");
|
|
+ }
|
|
+ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
|
|
+ (gtk_minor_version != GTK_MINOR_VERSION) ||
|
|
+ (gtk_micro_version != GTK_MICRO_VERSION))
|
|
+ {
|
|
+ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
|
|
+ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
|
|
+ printf("*** library (version %d.%d.%d)\n",
|
|
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
|
+ }
|
|
+ else
|
|
+ {
|
|
+ if ((gtk_major_version > major) ||
|
|
+ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
|
|
+ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
|
|
+ {
|
|
+ return 0;
|
|
+ }
|
|
+ else
|
|
+ {
|
|
+ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
|
|
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
|
|
+ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
|
|
+ major, minor, micro);
|
|
+ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
|
|
+ printf("***\n");
|
|
+ printf("*** If you have already installed a sufficiently new version, this error\n");
|
|
+ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
|
|
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
|
|
+ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
|
|
+ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
|
|
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
|
|
+ printf("*** so that the correct libraries are found at run-time))\n");
|
|
+ }
|
|
+ }
|
|
+ return 1;
|
|
+}
|
|
+],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
|
|
+ CFLAGS="$ac_save_CFLAGS"
|
|
+ LIBS="$ac_save_LIBS"
|
|
+ fi
|
|
+ fi
|
|
+ if test "x$no_gtk" = x ; then
|
|
+ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
|
|
+ ifelse([$2], , :, [$2])
|
|
+ else
|
|
+ AC_MSG_RESULT(no)
|
|
+ if test "$PKG_CONFIG" = "no" ; then
|
|
+ echo "*** A new enough version of pkg-config was not found."
|
|
+ echo "*** See http://pkgconfig.sourceforge.net"
|
|
+ else
|
|
+ if test -f conf.gtktest ; then
|
|
+ :
|
|
+ else
|
|
+ echo "*** Could not run GTK+ test program, checking why..."
|
|
+ ac_save_CFLAGS="$CFLAGS"
|
|
+ ac_save_LIBS="$LIBS"
|
|
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
|
|
+ LIBS="$LIBS $GTK_LIBS"
|
|
+ AC_TRY_LINK([
|
|
+#include <gtk/gtk.h>
|
|
+#include <stdio.h>
|
|
+], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
|
|
+ [ echo "*** The test program compiled, but did not run. This usually means"
|
|
+ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
|
|
+ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
|
|
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
|
|
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
|
|
+ echo "*** is required on your system"
|
|
+ echo "***"
|
|
+ echo "*** If you have an old version installed, it is best to remove it, although"
|
|
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
|
|
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
|
|
+ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
|
|
+ CFLAGS="$ac_save_CFLAGS"
|
|
+ LIBS="$ac_save_LIBS"
|
|
+ fi
|
|
+ fi
|
|
+ GTK_CFLAGS=""
|
|
+ GTK_LIBS=""
|
|
+ ifelse([$3], , :, [$3])
|
|
+ fi
|
|
+ AC_SUBST(GTK_CFLAGS)
|
|
+ AC_SUBST(GTK_LIBS)
|
|
+ rm -f conf.gtktest
|
|
+])
|
|
diff -Naur lame-3.98.4/Makefile.am lame-3.98.4.patch/Makefile.am
|
|
--- lame-3.98.4/Makefile.am 2010-02-26 23:33:06.000000000 +0100
|
|
+++ lame-3.98.4.patch/Makefile.am 2011-03-25 12:15:37.951078720 +0100
|
|
@@ -2,6 +2,8 @@
|
|
|
|
include $(top_srcdir)/Makefile.am.global
|
|
|
|
+ACLOCAL_AMFLAGS = -I m4
|
|
+
|
|
.PHONY: test
|
|
|
|
SUBDIRS = mpglib libmp3lame frontend Dll debian doc include misc dshow ACM \
|