distribution/packages/emulators/libretro/easyrpg-lr/liblcf/patches/liblcf-02-add-icu-compile-defs.patch
2023-03-17 21:06:43 +00:00

12 lines
439 B
Diff

--- a/CMakeLists.txt 2020-12-20 15:19:33.535997406 +0100
+++ b/CMakeLists.txt 2020-12-20 15:21:56.337546477 +0100
@@ -259,6 +259,9 @@
else()
find_package(ICU COMPONENTS i18n uc data REQUIRED)
target_link_libraries(lcf ICU::i18n ICU::uc ICU::data)
+ INCLUDE(FindPkgConfig)
+ pkg_get_variable(ICUDEFS icu-i18n DEFS)
+ target_compile_definitions(lcf PRIVATE LCF_SUPPORT_ICU=1 ${ICUDEFS})
list(APPEND LIBLCF_DEPS "icu-i18n")
endif()