11cb17b3cf
* Create package.mk * Create 01-EmuELEC-fix-arm-compile.patch * Rename packages/games/emulators/flycastsa/patches/01-EmuELEC-fix-arm-compile.patch to packages/games/emulators/flycastsa/patches/arm/01-EmuELEC-fix-arm-compile.patch * Create 03-EmuELEC-fix-sdl-controller.patch * Rename packages/games/emulators/flycastsa/patches/arm/03-EmuELEC-fix-sdl-controller.patch to packages/games/emulators/flycastsa/patches/03-EmuELEC-fix-sdl-controller.patch * Create flycast.sh * Create set_flycast_joy.sh * Update package.mk * Update package.mk * No longer need second patch. * Update 01-EmuELEC-fix-arm-compile.patch * Delete packages/games/emulators/flycastsa/patches/arm directory * Update package.mk * Create 01-fix-zip.patch * Update 01-fix-zip.patch * Update 01-fix-zip.patch * Delete packages/games/emulators/flycastsa/patches/arm directory * Update package.mk * Update runemu.sh * Create 01-platform.patch * Update 03-EmuELEC-fix-sdl-controller.patch * Update package.mk * Update 03-EmuELEC-fix-sdl-controller.patch * Update 03-EmuELEC-fix-sdl-controller.patch * Update 03-EmuELEC-fix-sdl-controller.patch * Rename 03-EmuELEC-fix-sdl-controller.patch to 03-fix-sdl-controller.patch * Create 01-fix-zip-error.patch * Update 01-fix-zip-error.patch * Update 01-fix-zip-error.patch * Update package.mk * Delete 01-fix-zip-error.patch * flycastsa updates * flycastsa update2
27 lines
757 B
Diff
27 lines
757 B
Diff
diff --git a/core/archive/ZipArchive.cpp b/core/archive/ZipArchive.cpp
|
|
index 394f919a..58cd295e 100644
|
|
--- a/core/archive/ZipArchive.cpp
|
|
+++ b/core/archive/ZipArchive.cpp
|
|
@@ -27,20 +27,8 @@ ZipArchive::~ZipArchive()
|
|
|
|
bool ZipArchive::Open(const char* path)
|
|
{
|
|
- FILE *file = nowide::fopen(path, "rb");
|
|
- if (file == nullptr)
|
|
- return false;
|
|
- zip_error_t error;
|
|
- zip_source_t *source = zip_source_filep_create(file, 0, -1, &error);
|
|
- if (source == nullptr)
|
|
- {
|
|
- std::fclose(file);
|
|
- return false;
|
|
- }
|
|
- zip = zip_open_from_source(source, 0, NULL);
|
|
- if (zip == nullptr)
|
|
- zip_source_free(source);
|
|
- return zip != nullptr;
|
|
+ zip = zip_open(path, 0, NULL);
|
|
+ return (zip != NULL);
|
|
}
|
|
|
|
ArchiveFile* ZipArchive::OpenFile(const char* name)
|