distribution/packages/emulators/standalone/ppsspp-sa/patches/003-disable-mouse.patch
fewtarius 207f8d8f69
* Update emulators, cores, and emulation support packages.
* box64, a5200-lr, atari800-lr, beetle-pce-fast-lr, beetle-pce-lr, beetle-psx-lr, bsnes-lr, package.mk, desmume-lr, dosbox-pure-lr, fbneo-lr, flycast-lr, genesis-plus-gx-lr, genesis-plus-gx-wide-lr, handy-lr, package.mk, mame-lr, mame2003-plus-lr, mupen64plus-nx-lr, opera-lr, pcsx_rearmed-lr, picodrive-lr, play-lr, ppsspp-lr, stella-lr, swanstation-lr, tic80-lr, cemu-sa, duckstation-sa, hatarisa, package.mk, ppsspp-sa, primehack, retroarch, scummvmsa, yuzu-sa, glsl-shaders, slang-shaders, and retroarch-joypads.
* Fix pipewire package oops.
2023-08-11 20:52:46 +00:00

40 lines
1.3 KiB
Diff

diff --git a/SDL/SDLMain.cpp b/SDL/SDLMain.cpp
index 86bd19131..99bc80d1f 100644
--- a/SDL/SDLMain.cpp
+++ b/SDL/SDLMain.cpp
@@ -795,12 +795,7 @@ static void ProcessSDLEvent(SDL_Window *window, const SDL_Event &event, InputSta
g_Config.iWindowWidth = new_width;
g_Config.iWindowHeight = new_height;
}
- // Hide/Show cursor correctly toggling fullscreen
- if (lastUIState == UISTATE_INGAME && fullscreen && !g_Config.bShowTouchControls) {
- SDL_ShowCursor(SDL_DISABLE);
- } else if (lastUIState != UISTATE_INGAME || !fullscreen) {
- SDL_ShowCursor(SDL_ENABLE);
- }
+ SDL_ShowCursor(SDL_DISABLE);
break;
}
@@ -1382,9 +1377,7 @@ int main(int argc, char *argv[]) {
printf("Init from thread error: '%s'\n", error_message.c_str());
}
-#ifdef MOBILE_DEVICE
SDL_ShowCursor(SDL_DISABLE);
-#endif
if (!useEmuThread) {
NativeInitGraphics(graphicsContext);
@@ -1436,10 +1429,7 @@ int main(int argc, char *argv[]) {
#if !defined(MOBILE_DEVICE)
if (lastUIState != GetUIState()) {
lastUIState = GetUIState();
- if (lastUIState == UISTATE_INGAME && g_Config.UseFullScreen() && !g_Config.bShowTouchControls)
- SDL_ShowCursor(SDL_DISABLE);
- if (lastUIState != UISTATE_INGAME || !g_Config.UseFullScreen())
- SDL_ShowCursor(SDL_ENABLE);
+ SDL_ShowCursor(SDL_DISABLE);
}
#endif